[ระวังให้ดี] เตือนช่องโหว่ BlueBorne อุปกรณ์บลูทูธกว่า 5,300 ล้านเครื่องตกอยู่ในความเสี่ยง

นักวิจัยจาก Armis บริษัทผู้ให้บริการระบบรักษาความมั่นคงปลอดภัยสำหรับอุปกรณ์ IoT ออกมาแจ้งเตือนถึงช่องโหว่รวมทั้งหมด 8 รายบนอุปกรณ์ที่รองรับการใช้บลูทูธกว่า 5,300 ล้านเครื่องทั่วโลก ที่น่ากลัวคือแฮ็คเกอร์สามารถโจมตีอุปกรณ์เหล่านั้นได้โดยที่ไม่ต้องเข้าถึงอุปกรณ์เหล่านั้น หรือทำการ Pair ใดๆ ช่องโหว่ทั้ง 8 รายการนี้ถูกเรียกรวมกันว่า “BlueBorne”

blueborne_vuln_1.png

BlueBorne ส่งผลกระทบต่ออุปกรณ์บลูทูธทั่วโลก ไม่ว่าจะเป็นระบบปฏิบัติการ Android, Apple iOS, Microsoft หรือ Linux ตั้งแต่สมาร์ทโฟน แท็บเล็ต โน๊ตบุ๊ค อุปกรณ์ IoT Home Automation ไปจนถึงรถยนต์อัจฉริยะรวมแล้วกว่า 5,300 ล้านเครื่อง

3 ใน 8 ของช่องโหว่ถูกจัดให้มีความรุนแรงระดับ Critical โดย Armis ระบุว่า ช่องโหว่เหล่านี้ช่วยให้แฮ็คเกอร์สามารถเข้าควบคุมหรือรันคำสั่งแปลกปลอมบนอุปกรณ์ได้ทันที รวมไปถึงสามารถโจมตีแบบ Man-in-the-Middle เพื่อดักฟังข้อมูลจากการเชื่อมต่อบลูทูธได้อีกด้วย นอกจากนี้ยังสามารถนำหลายๆ ช่องโหว่มาใช้งานร่วมกันเพื่อสร้าง Worm สำหรับแพร่กระจายตัวผ่านบลูทูธเพื่อสร้างความเสียแก่ระบบเครือข่ายได้

“ช่องโหว่เหล่านี้เป็นช่องโหว่บนบลูทูธที่ซีเรียสที่สุดที่ค้นพบจนถึงปัจจุบัน ช่องโหว่บนบลูทูธที่ถูกค้นพบก่อนหน้านี้ส่วนใหญ่เป็นช่องโหว่ระดับโปรโตคอล แต่ช่องโหว่ใหม่เหล่านี้เป็นช่องโหว่ในระดับการพัฒนาเทคโนโลยี ซึ่งสามารถบายพาสกลไกการพิสูจน์ตัวตน และเข้าควบคุมอุปกรณ์เป้าหมายได้อย่างสมบูรณ์” — โฆษกจาก Armis กล่าว

รหัส CVE ที่เกี่ยวข้อง

  • Android: CVE-2017-0781, CVE-2017-0782, CVE-2017-0783 และ CVE-2017-0785
  • Linux: CVE-2017-1000251 และ CVE-2017-1000250
  • Windows: CVE-2017-8628
  • Apple: อยู่ระหว่างรอระบุรหัส CVE

อุปกรณ์ที่ได้รับผลกระทบ

  • สมาร์โฟน แท็บเล็ต และอุปกรณ์สวมใส่ที่รันระบบปฏิบัติการ Android ทุกเวอร์ชันได้รับผลกระทบจากช่องโหว่ 4 รายการตามที่ได้กล่าวไป ยกเว้นอุปกรณ์ที่รัน Bluetooth Low Energy
  • ระบบปฏิบัติการ Windows นั้น ตั้งแต่เวอร์ชัน Vista เป็นต้นไปได้รับผลกระทบ ยกเว้น Windows Phone
  • อุปกรณ์ Linux ทุกรุ่นที่รัน BlueZ จะได้รับผลกระทบจากช่องโหว่การรั่วไหลของข้อมูล ในขณะที่อุปกรณ์ Linux อื่นๆ ตั้งแต่เวอร์ชัน 3.3-rc1 (ออกเมื่อตุลาคม 2011) จะได้รับผลกระทบจากช่องโหว่ Remote Code Execution
  • iPhone, iPad และ iPod Touch ที่รัน iOS 9.3.5 หรือก่อนหน้านั้น และ Apple TV เวอร์ชัน 7.2.2 หรือก่อนหน้านั้นต่างได้รับผลกระทบทั้งสิ้น อย่างไรก็ตาม Apple ได้ออกแพทช์อุดช่องโหว่ตั้งแต่ iOS 10 เป็นที่เรียบร้อย

Armis ได้แจ้งช่องโหว่ที่ค้นพบไปยังผู้ผลิตซอฟต์แวร์รายใหญ่แล้ว ไม่ว่าจะเป็น Apple, Google, Microsoft และ Linux Community ซึ่ง Microsoft ได้ออกแพทช์สำหรับอุดช่องโหว่ดังกล่าวบน Windows Bluetooth Driver ใน Microsoft Patch Tuesday ตั้งแต่เมื่อเดือนกรกฎาคมที่ผ่านมา แต่เพิ่งเปิดเผยรายละเอียดใน Patch Tuesday เดือนนี้ ส่วน Google ก็ได้ออกแพทช์อุดช่องโหว่บน Android ใน Security Bulletin ประจำเดือนกันยายนเช่นเดียวกัน สำหรับผู้ผลิตรายอื่นๆ คาดว่าจะออกแพทช์เพื่ออุดช่องโหว่เร็วๆ นี้ อย่างไรก็ตาม คาดว่ามีอุปกรณ์บลูทูธทั่วโลกประมาณ 40% ที่จะไม่ได้อัปแพทช์เนื่องจากเป็นอุปกรณ์เก่าที่ End-of-Life ไปแล้ว

ทั้งนี้ ผู้ใช้ทั่วไปที่รอแพทช์ (หรือไม่สามารถอัปเดตแพทช์ได้) สามารถป้องกันอุปกรณ์บลูทูธของตนเองจากช่องโหว่ BlueBorne ได้ด้วยการปิดบลูทูธ และเปิดใช้งานเฉพาะเมื่อจำเป็นต้องใช้เท่านั้น ส่วนผู้ใช้ Android สามารถตรวจสอบว่าอุปกรณ์ของตนมีช่องโหว่หรือไม่จากแอพพลิเคชัน BlueBorne Android App(ดาวน์โหลดได้ผ่านทาง Google Play)

รายละเอียดเชิงเทคนิค: http://go.armis.com/hubfs/BlueBorne%20Technical%20White%20Paper.pdf

ที่มา: https://www.bleepingcomputer.com/news/security/blueborne-vulnerabilities-impact-over-5-billion-bluetooth-enabled-devices/

ใส่ความเห็น

Please log in using one of these methods to post your comment:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out /  เปลี่ยนแปลง )

Google+ photo

You are commenting using your Google+ account. Log Out /  เปลี่ยนแปลง )

Twitter picture

You are commenting using your Twitter account. Log Out /  เปลี่ยนแปลง )

Facebook photo

You are commenting using your Facebook account. Log Out /  เปลี่ยนแปลง )

w

Connecting to %s